Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Lustre 1.8.7
    • Fix Version/s: None
    • Labels:
    • Environment:
      Red Hat Enterprise Linux 5.7 + lustre 1.8.7-wc1
    • Severity:
      1
    • Epic:
    • Rank (Obsolete):
      6438

      Description

      We add two new OSS server and we would like to redistribute the OST on these 2 new OSS.
      The old OSS are:

      • 10.121.13.31@tcp
      • 10.121.13.62@tcp
        The new OSS are:
      • 10.121.13.59@tcp
      • 10.121.13.28@tcp

      I have un-mounted all the clients, and the mgt, mdt, osts. I want to change the allocation of ost06 from 10.121.13.62@tcp to 10.121.13.28@tcp. The original configuration of ost06 was:
      Parameters: mgsnode=10.121.13.31@tcp failover.node=10.121.13.31@tcp ost.quota_type=ug
      and the ost06 was hosted on 10.121.13.62@tcp

      I have use tunefs.lustre to modify the ost configuration with this command line:
      tunefs.lustre --erase-param --mgsnode=10.121.13.31@tcp --mgsnode=10.121.13.62@tcp --param="failover.node=10.121.13.59@tcp ost_quota=ug" --writeconf /dev/mapper/ost06p1
      I want host the ost06 on 10.121.13.28@tcp with a failover on 10.121.13.59@tcp

      When I starting up, I see in the logs that the mds try to connect to OST0006 on 10.121.13.62@tcp and give some ost_connection error.

      Could you provide me the correct procedure to relocate the ost06 ?

      Thanks in advanced

        Attachments

          Activity

            People

            • Assignee:
              cliffw Cliff White (Inactive)
              Reporter:
              lustre.support Supporto Lustre Jnet2000
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: