Uploaded image for project: 'Lustre'
  1. Lustre
  2. LU-12083

Interop: conf-sanity test 100 fails with 'lshowmount have no output MGS'

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: Lustre 2.10.7
    • Fix Version/s: None
    • Labels:
    • Environment:
      Interop testing
    • Severity:
      3
    • Rank (Obsolete):
      9223372036854775807

      Description

      conf-sanity test_100 fails in interop testing with 'lshowmount have no output MGS'

      Looking at a recent failure, 2.10.7 RC1 clients and 2.7.x servers, at https://testing.whamcloud.com/test_sets/bf2c7fb0-4306-11e9-92fe-52540065bddc, we see the following in the client test_log

      setup single mount lustre success
      CMD: trevis-54vm12 lshowmount -v
      trevis-54vm12: sh: lshowmount: command not found
       conf-sanity test_100: @@@@@@ FAIL: lshowmount have no output MGS 
      

      The patch for LU-8599, https://review.whamcloud.com/17593/, we see that conf-sanity test 100 was added to Lustre version 2.8.59. Thus, it’s clear that we need to add a Lustre version check for this test and not run this test for all interop testing with servers with version less than 2.8.59.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                wc-triage WC Triage
                Reporter:
                jamesanunez James Nunez
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: