Uploaded image for project: 'Lustre'
  1. Lustre
  2. LU-12141

Wrong requires kernel version detected of lustre kmod built against target rhel7.6

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Upstream
    • Fix Version/s: Lustre 2.13.0, Lustre 2.12.1
    • Labels:
      None
    • Severity:
      3
    • Rank (Obsolete):
      9223372036854775807

      Description

      ./lbuild --distro=rhel7 --lustre=../../$tarball --target=3.10-rhel7.6 --reusebuild=/work/jenkins/reusebuild --kernelrpm=/work/jenkins/kernelrpm --kerneltree=/work/jenkins/kerneltree --release --disable-zfs --ccache  -- --with-o2ib=no --without-zfs --disable-lru-resize
      
      
      # rpm -ivh kernel-3.10.0-957.1.3.el7_lustre.2.12.52_52_gae723cf_dirty.x86_64.rpm kmod-lustre-2.12.52_52_gae723cf-1.el7.x86_64.rpm
      error: Failed dependencies: kernel < 3.10.0-863 is needed by kmod-lustre-2.12.52_52_gae723cf-1.el7.x86_64

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                guzheng Gu Zheng
                Reporter:
                guzheng Gu Zheng
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: