Uploaded image for project: 'Lustre'
  1. Lustre
  2. LU-12395

Failed dependencies while installing lustre-client-tests and lustre-iokit rpms on RHEL 8.0 client

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Lustre 2.13.0, Lustre 2.12.3
    • Labels:
      None
    • Severity:
      3
    • Rank (Obsolete):
      9223372036854775807

      Description

      While installing lustre-client-tests and lustre-iokit rpms on RHEL 8.0 client, they hit the following dependency issues:

      error: Failed dependencies:
      	libmpi.so.40()(64bit) is needed by lustre-client-tests-2.12.54-1.el8.x86_64
      	python > 2.2 is needed by lustre-iokit-2.12.54-1.el8.x86_64
      

      On RHEL 8.0, openmpi provides "libmpi.so.40()(64bit)(openmpi-x86_64)", not "libmpi.so.40()(64bit)". There are python2 and python3 on RHEL 8.0, no python.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dongyang Dongyang Li
                Reporter:
                yujian Jian Yu
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: