Uploaded image for project: 'Lustre'
  1. Lustre
  2. LU-12989

interop: replay-single test 134 fails with 'file does not exist'

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: Lustre 2.13.0, Lustre 2.14.0
    • Fix Version/s: None
    • Labels:
    • Environment:
      servers with Lustre version < 2.12.53 and clients >= 2.12.53
    • Severity:
      3
    • Rank (Obsolete):
      9223372036854775807

      Description

      replay-single test 134 fails with 'file does not exist'. In the suite_log, we see

      CMD: trevis-45vm12 /usr/sbin/lctl mark mds1 REPLAY BARRIER on lustre-MDT0000
      touch: setting times of '/mnt/lustre/d134.replay-single/f134.replay-single': No such file or directory
      Failing mds1 on trevis-45vm12
      ...
      trevis-45vm10: mdc.lustre-MDT0000-mdc-*.mds_server_uuid in FULL state after 0 sec
       replay-single test_134: @@@@@@ FAIL: file does not exist 
        Trace dump:
        = /usr/lib64/lustre/tests/test-framework.sh:6108:error()
        = /usr/lib64/lustre/tests/replay-single.sh:4906:test_134()
      

      replay-single test_134 was added with patch https://review.whamcloud.com/34371/ for Lustre version 2.12.53 and is not in b2_12 and earlier versions of Lustre. This test should be skipped for Lustre server versions 2.12.52 and earlier.

      Logs for these failures are at
      https://testing.whamcloud.com/test_sets/a48dc48c-cc4c-11e9-90ad-52540065bddc
      https://testing.whamcloud.com/test_sets/d31c6872-07a6-11ea-bbc3-52540065bddc

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                wc-triage WC Triage
                Reporter:
                jamesanunez James Nunez
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: