Uploaded image for project: 'Lustre'
  1. Lustre
  2. LU-812

Support for Linux 3.0 kernels

    XMLWordPrintable

Details

    • Improvement
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • None
    • Lustre 2.4.0
    • None
    • 4458

    Description

      Cray is interested in bringing Linux 3.0 support to clients and servers. We'll focus on clients first since that will obviously be easiest. However, Lustre won't even configure in a Linux 3.0 environment. Initially, we plan on submitting patches to the build process going. Eventually, we'll work our way up to the server patch series. Of course, the BKL was removed and we'll be looking for suggestions on how to work around that and other major changes. I presume that RHEL will go to Linux 3.x eventually, but Cray will initially be focusing on SLES SP2. Hopefully we can find a way to make the patch sets similar.

      We'd like to at least have 3.0 clients be considered upstream for Lustre 2.3.

      Attachments

        1. 3.0-client-patches.tar.gz
          17 kB
        2. 3.0-client-patches.tar.gz
          17 kB
        3. mutex.diff
          187 kB
        4. no-autoconf-included.patch
          19 kB

        Issue Links

          Activity

            People

              ys Yang Sheng
              spitzcor Cory Spitz
              Votes:
              3 Vote for this issue
              Watchers:
              21 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: