Details

    • Type: Technical task
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Lustre 2.10.0
    • Fix Version/s: Lustre 2.10.0
    • Labels:
    • Rank (Obsolete):
      9223372036854775807

      Description

      While trying to create a file with many components, I ran into a few problems. Firstly, I tried creating a file with no layout, and then adding components to the file in a loop:

      # mcreate /mnt/testfs/comp
      # for C in {1..50}; do lfs setstripe --component-add -E ${C}M -c 1 /mnt/testfs/comp; done
      
      First extent to be set [0, 1048576) isn't adjacent with the existing file extent
       end: 18446744073709551615
      Create a new file with a specific striping pattern or
      set the default striping pattern on an existing directory or
      delete the default striping pattern from an existing directory or
      add layout component(s) to an existing composite file or
      delete specified component(s) from an existing composite file
      

      I think this is a bug, since there is no previous component, and the "end" should be 0 which would allow this to succeed. Then I tried to add only the first component without --component-add, but this also failed even though there is no layout yet:

      # lfs getstripe /mnt/testfs/comp
      /mnt/testfs/comp has no stripe info
      # lfs setstripe --component-add -E 1M -c 1 /mnt/testfs/comp
      Create composite file /mnt/testfs/comp failed. File exists
      error: setstripe: create composite file '/mnt/testfs/comp' failed: File exists
      

        Attachments

          Activity

            People

            • Assignee:
              niu Niu Yawei (Inactive)
              Reporter:
              adilger Andreas Dilger
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: