Uploaded image for project: 'Lustre'
  1. Lustre
  2. LU-10626

utils/tests: lctl set_param -P does not appear to do anything

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Lustre 2.12.0
    • Labels:
    • Severity:
      3
    • Rank (Obsolete):
      9223372036854775807

      Description

      When running sanity-hsm on a single node setup I run into this error:

      Set HSM on and start
      Waiting 20 secs for update
      Waiting 10 secs for update
      Update not seen after 20s: wanted 'enabled' got 'stopped'
       sanity-hsm : @@@@@@ FAIL: hsm_control state is not 'enabled' on mds1 
        Trace dump:
        = /home/guest/lustre-release/lustre/tests/test-framework.sh:5336:error()
        = /home/guest/lustre-release/lustre/tests/sanity-hsm.sh:617:mdts_check_param()
        = /home/guest/lustre-release/lustre/tests/sanity-hsm.sh:723:cdt_check_state()
        = /home/guest/lustre-release/lustre/tests/sanity-hsm.sh:1005:main()
      

      It seems lctl set_param -P mdt.*.hsm_control enabled silently fails. I do not know if it was recently modified... I tested it on other hsm tunables, it did not work either. Without the -P option, everything works fine.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                simmonsja James A Simmons
                Reporter:
                bougetq Quentin Bouget
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: