Uploaded image for project: 'Lustre'
  1. Lustre
  2. LU-11555

warn when mounting ZFS pools without "multihost" enabled

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Lustre 2.12.0, Lustre 2.10.5
    • Fix Version/s: Lustre 2.13.0, Lustre 2.12.1
    • Labels:
      None
    • Rank (Obsolete):
      9223372036854775807

      Description

      It would be good to warn when importing a pool that does not have the multihost feature enabled, so that users are aware that their pool is exposed to potential data loss in case of double import.

      Ideally, this message would only be printed in the case that the OST is configured to be multi-homed (-failnode or -servicenode configured), but it isn't clear that the configuration layer that understands peers knows the pool is ZFS and vice versa. Since we enable multihost for all new pools since 2.10.1 there will hopefully be a relatively smaller number of sites not using this feature. It is not harmful (though not useful) if it is enabled for ZFS 0.6.x, so it might be worthwhile to print a slightly different message for ZFS 0.6.x encouraging the system to be upgraded.

        Attachments

          Activity

            People

            • Assignee:
              utopiabound Nathaniel Clark
              Reporter:
              adilger Andreas Dilger
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: