Uploaded image for project: 'Lustre'
  1. Lustre
  2. LU-8730

interop: 2.1(server)<->2.8(client): conf-sanity test_82: mkfs.lustre FATAL: Bad argument: /dev/vdb

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Lustre 2.1.6
    • Fix Version/s: Lustre 2.10.0
    • Labels:
    • Environment:
      Interop: 2.1.6 <-> 2.8.0
      server- 2.1.6 and older.
      client- after 2.7.
    • Severity:
      3
    • Rank (Obsolete):
      9223372036854775807

      Description

      In conf-sanity_test_83 two appearance of "$dev" var will give reported error when server is 2.1 or older.

              add ost1 $(mkfs_opts ost1 $dev) $FSTYPE_OPT \
                      --reformat $dev $dev > /dev/null ||
                      error "format ost1 error"
      

      Although it is clear that check is added to to skip the test if the ost version is older than 2.6.91

      [[ $(lustre_version_code ost1) -ge $(version_code 2.6.91) ]] ||
                      { skip "Need OST version at least 2.6.91" && return 0; }
      

      still as a good coding practice that parameter is erroneous hence should be removed.

        Attachments

          Activity

            People

            • Assignee:
              wc-triage WC Triage
              Reporter:
              ashish.maurya Ashish Maurya (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: